Credit Card processing failing

Major incident Website (lutify.me) Billing
2019-06-09 09:37 IST · 12 hours, 38 minutes

Updates

Resolved

The issue is now resolved. All credit card orders are processing correctly.

November 4, 2021 · 17:24 IST
Investigating

Issue is still occurring intermittently. Some orders are processing correctly while others are timing out. We will update as soon as there is a change.

November 4, 2021 · 17:24 IST
Monitoring

Issue appears to be resolved, however we’re proactively monitoring the situation to make sure this issue is behind us. While we are monitoring the situation we’re leaving the issue as open. We will update once again, as soon as we are positive issue is completely resolved.

November 4, 2021 · 17:24 IST
Investigating

Some orders are now processing on the processor side, however our service isn’t receiving a payment confirmation from our credit card processor, causing the orders to appear as ‘pending payment’ on our side. As our service is unable to verify payments, download links aren’t generated after order. Again, we recommend using PayPal option in the meantime. We will update as soon as we see progress.

November 4, 2021 · 17:24 IST
Investigating

Credit card processing issue is affecting both new and recurring orders. New orders fail and their subsequent subscriptions are immediately cancelled as a result of that. Recurring subscriptions, will be queued and processed once an issue is resolved. Current Lutify.me subscribers may receive an email about failed subscription renewal order. If you paid for your subscription by credit card it is safe to ignore that message for now. New customers, please use PayPal as an alternative payment method until this issue is resolved.

November 4, 2021 · 17:24 IST
Issue

We are experiencing an issue with our credit card processor which is causing orders to fail at this time. This issue affects both new and recurring orders. Until the issue is resolved, please use PayPal as an alternative payment method to place a new order. All recurring orders will be queued and processed once the issue has been resolved.

November 4, 2021 · 17:24 IST

← Back